Migrating from 2.1 to 2.2

JDK8

We’ve dropped support for JDK7 and now require JDK8.

Global changes

  • The format of a few configuration properties in gatling.conf has changed and must be updated to its new form.

    Where the values took the form "value1, value2, value3", it must be changed to : [value1, value2, value3].

    This impacts three configuration properties :

    • gatling.http.ahc.httpsEnabledProtocols : by default "", now []
    • gatling.http.ahc.httpsEnabledCipherSuites : by default "", now []
    • gatling.data.writers : by default "console, file", now [console, file]
  • Some configuration options have been renamed or dropped, please check the logs or update to a fresh gatling.config file copy.

Core

doIf(actual, expected) that only execute wrapped block when actual evaluates to expected was renamed into doIfEquals for clarity and consistency.

Pauses

normalPauses(stdDev: Double) was confusing and was replaced by normalPausesWithPercentageDuration(stdDev: Double) and normalPausesWithStdDevDuration(stdDev: Duration)

HTTP

Protocol

A typo was fixed and connection was renamed into connectionHeader.

ElFileBody

ELFileBody has been renamed to ElFileBody.

Check

latencyInMillis was dropped, as this metric (time between last byte sent and first by received) didn’t make sense for most people and only brought confusion.`

Local Address

localAddress is now only available at HTTP protocol level, not request, and take one or many Strings, instead of a single Expression[InetAddress]`.

Reports

latency charts were dropped, as this metric (time between last byte sent and first by received) didn’t make sense for most people and only brought confusion.

Maven Plugin

execute task is now deprecated and will be removed in a future version. Please now use test and integration-test.

Reports files are now generated in /target/gatling instead of /target/results.

SBT Plugin

In order to not conflict with “standard” tests frameworks, you’re now required to prefix your command with gatling:, e.g. gatling:test instead of test.